Trucos en Excel utilizando la función CONTAR.SI - No Solo Moda

¡Lo ultimo!

Post Top Ad

Post Top Ad

viernes, mayo 01, 2015

Trucos en Excel utilizando la función CONTAR.SI

La función CONTAR.SI nos puede proporcionar bastante información útil. De un rango determinado se puede contar las celdas vacías, no vacías, o celdas con todo texto. 

Veámoslo con un ejemplo.




Qué hace esta función?


Cuenta las celdas de un rango que cumplen una condición especificada.

Sintaxis:

CONTAR.SI(rango, criterio)


  • rango (obligatorio): El rango del que se desea contar el número de celdas que no están en blanco.
  • criterio (obligatorio): La condición que se debe cumplir para ser incluido en la cuenta.

Ejemplos: 


=CONTAR.SI(A1:A3, “>1″) = 2 si A1:A3={1,2,3}
=CONTAR.SI(B1:B3, “contar”) = 1 si B1:B3 ={“sumar”,”contar”,”sumar”}


Volviendo a nuestro ejemplo, teniendo un rango B2:B9 con los valores indicados, vamos a realizar varios cálculos.

Calcular las celdas vacías


Para ello se podrían emplear las siguientes fórmulas:

=CONTAR.SI(B2:B9,"=") = 1

=CONTAR.SI(B2:B9,"") = 1

Y también utilizar la función CONTAR.BLANCO

=CONTAR.BLANCO(B2:B9) = 1


Calcular las celdas que son texto


Para ello se podrían emplear las siguientes fórmulas:

=CONTAR.SI(B2:B9,"><") = 3

=CONTAR.SI(B2:B9,"*") = 3


Calcular las celdas no vacías


Para ello se podrían emplear las siguientes fórmulas:


=CONTAR.SI(B2:B9,"<>") = 7

Y también utilizar la función CONTARA

=CONTARA(B2:B9) = 7 




Sabéis alguno más?


Si sabes algún truco más compártelo dejándolo en los comentarios.


                      



-----------------------------------------------------------------------------------------

Sobre el Autor:

Soy un apasionado de Excel desde la primera vez que lo usé. Con más de 15 años de experiencia y con muchas horas como usuario, decidí crear El sabio de Excel para compartir más información, técnicas, trucos, consejos y más sobre esta increíble herramienta.

No hay comentarios:

Publicar un comentario

Post Top Ad